wiki:Release/0.5/Announce/RC2

GeoExt 0.5 RC2 Announcement

The GeoExt community is proud to announce the second release candidate of GeoExt 0.5, the first GeoExt version to be released.

RC2 closes a small number of bugs in the 0.5 release, most importantly a fix for the LayerStore providing layers in the wrong order. Also from now on, releases will have the version number available in the GeoExt.VERSION_NUMBER constant.

We invite you to help us test the 0.5 release candidate! To test in your applications, please download [1], unzip it to the root of your GeoExt powered application, and include the following script tag in your html:

<script src="GeoExt/script/GeoExt.js"></script>

GeoExt 0.5 depends on OpenLayers >= 2.8 and ExtJS >= 2.2.

The source is available on svn at [2]. Bug reports can be filed in Trac, under the 0.5 RC2 version and 0.5 milestone, at [3].

The 0.5 release comes with a number of important features, the full list of which can be found in the Release Notes, at [4]. Some of the highlights include:

  • MapPanel to integrate OpenLayers maps in ExtJS applications
  • LegendPanel to display legends for WMS layers
  • LayerNodes and LayerContainers to create customized layer switchers
  • Popups as anchored Ext windows
  • Various Ext data components for convenient handling of OpenLayers layers, vector features and WMS Capabilities documents

We look forward to your feedback on this release.

[1] http://tinyurl.com/geoext-0-5-rc2
[2] http://svn.geoext.org/core/tags/geoext/release-0.5-rc2/
[3] http://www.geoext.org/trac/geoext/newticket
[4] http://www.geoext.org/trac/geoext/wiki/Release/0.5/Notes

Last modified 8 years ago Last modified on 07/02/09 11:03:56