Opened 6 years ago

Closed 6 years ago

#449 closed defect (duplicate)

WMSLegend with multiple legend entries should be vertically aligned

Reported by: gernot Owned by:
Priority: major Milestone: 1.1
Component: GeoExt.WMSLegend Version: 1.0
Keywords: Cc:
State: None

Description

When a WMSLegend shows a WMS layer containing multiple legend entries, the entries are aligned horizontally instead of vertically, which should be the default (for comparison: a VectorLegend containing multiple legend entries is always aligned vertically).

Please find attached images how it is and how it should be (at least in my opinion).

I fixed this (in a crude way, see attachment) by adding the LegendImage's into a new subcontainer with the 'column' style. Probably there is a more elegant way to achieve this, it works for me however.

Attachments (3)

WMSLegend.js.patch (2.9 KB) - added by gernot 6 years ago.
Hotfix for vertical WMSLegend against GeoExt-1.0
legend_before_patch.png (4.2 KB) - added by gernot 6 years ago.
legend_after_patch.png (3.6 KB) - added by gernot 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by gernot

Hotfix for vertical WMSLegend against GeoExt-1.0

comment:1 Changed 6 years ago by gernot

  • Type changed from enhancement to defect

Changed 6 years ago by gernot

Changed 6 years ago by gernot

comment:2 Changed 6 years ago by bartvde

  • Resolution set to duplicate
  • Status changed from new to closed

see #311 this can be completely done using CSS instead.

Note: See TracTickets for help on using tickets.