Opened 6 years ago

Closed 6 years ago

#433 closed enhancement (fixed)

failing tests in IE9

Reported by: bartvde Owned by:
Priority: major Milestone: 1.1
Component: GeoExt Version: 1.0
Keywords: Cc:
State: None

Description

We have some failing tests in IE9

Change History (6)

comment:1 Changed 6 years ago by bartvde

test_print fails in PrintProvider:

layers[5].geoJSON.features[0].id got undefined but expected f1

testOnImageLoadError fails in LegendImage:

called once for bogus img src: got 0 but expected 1

got bogus but expected also-bogus

comment:2 Changed 6 years ago by bartvde

Okay, the first issue is actually in OpenLayers.

comment:3 follow-up: Changed 6 years ago by bartvde

Actually the first test (PrintProvider) also fails in FF4 and Safari5, so it seems this testcase is not valid?

comment:4 in reply to: ↑ 3 Changed 6 years ago by bartvde

Replying to bartvde:

Actually the first test (PrintProvider) also fails in FF4 and Safari5, so it seems this testcase is not valid?

Right, this is the case, since OpenLayers fid maps to id:

        'feature': function(feature) {
            var geom = this.extract.geometry.apply(this, [feature.geometry]);
            var json = {
                "type": "Feature",
                "properties": feature.attributes,
                "geometry": geom
            };
            if (feature.fid != null) {
                json.id = feature.fid;
            }
            return json;
        },

so the testcase should use feature.fid = "f1"; instead of feature.id = "f1";

comment:5 Changed 6 years ago by bartvde

Testcase typo fixed in r2742

comment:6 Changed 6 years ago by bartvde

  • Resolution set to fixed
  • Status changed from new to closed

The failures in LegendImage are actually not reproduceable, so closing.

Note: See TracTickets for help on using tickets.