Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#382 closed defect (invalid)

LayerLegend: update function not safe

Reported by: bartvde Owned by:
Priority: major Milestone: 1.1
Component: GeoExt.LayerLegend Version: 1.0
Keywords: Cc:
State: None

Description

We are getting into situations where we get a javascript error on the update function of LayerLegend.

'this.items.get(...).text' is empty or no object

It seems a little code protection could be useful here.

Change History (2)

comment:1 Changed 7 years ago by bartvde

  • Resolution set to invalid
  • Status changed from new to closed

Sorry for the noise, this was fixed already in 1.0. Only an issue is 0.7.

comment:2 Changed 7 years ago by bartvde

Btw, for reference, this was a duplicate of ticket:291

Note: See TracTickets for help on using tickets.